最新消息:点击查看大S的省钱秘笈

CCNP实验:利用隧道扩展路由器模拟的帧中继交换机

CCNP实验 Slyar 150浏览 0评论

文章作者:姜南(Slyar) 文章来源:Slyar Home (www.slyar.com) 转载请注明,谢谢合作。

【实验环境】

C3640-IK9O3S-M Version 12.4(10)

【实验目的】

利用隧道技术扩展使用路由器模拟的帧中继交换机,弥补路由器接口有限造成的帧中继接口不足。

【实验拓扑】

【实验描述】

实验环境下,由于帧中继交换机价格昂贵,因此我们会使用路由器来模拟帧中继交换机,在真机环境下,有时会遇到路由器串行接口不够用的情况,因此我们就需要使用2台甚至更多台路由器进行模拟帧中继交换机的接口扩展,这时就需要用到隧道技术。

路由器R1和R2作为帧中继交换机,R1只有2个串行接口,因此需要使用快速以太网接口连接R3进行串行接口的扩展。

将路由器配置为帧中继交换机的命令详见《CCNP实验:将Cisco路由器配置为帧中继交换机》,这里不做过多描述,重点记录隧道的使用。因此配置只在R1与R2上进行,当帧中继云内部配置完成后,对用户来说就是透明的了。

【实验步骤】

1、R1基本配置,只配置了R3与R4之间的帧中继路由:

frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 304 interface Serial1/1 403
!
interface Serial1/1
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 403 interface Serial1/0 304
!
interface FastEthernet0/0
ip address 12.0.0.1 255.255.255.0
duplex auto
speed auto
!

2、R2基本配置,此时R2没有配置任何帧中继路由:

frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface FastEthernet0/0
ip address 12.0.0.2 255.255.255.0
duplex auto
speed auto
!

3、在R1上配置与R2之间的隧道

interface Tunnel1
tunnel source 12.0.0.1
tunnel destination 12.0.0.2

4、在R2上配置与R1之间的隧道

interface Tunnel1
tunnel source 12.0.0.2
tunnel destination 12.0.0.1

注意:这里隧道作p2p用,不需要配置IP地址,仅需要设置源和目的接口物理地址

5、在R1上配置R3->R5的帧中继路由

interface Serial1/0
frame-relay route 305 interface Tunnel1 101

6、在R2上配置R5->R3的帧中继路由

interface Serial1/0
frame-relay route 503 interface Tunnel1 101

注意:这里的对端DLCI号不可使用"305"和"503",需要使用一个唯一标识隧道的号码,用以区分通过隧道进行传输的多条PVC,这里的"101"可以随便定义(两边相同即可),当存在其他PVC时可以使用"102"、"103"等。

7、验证(在R1上使用"sh fr ro"命令查看帧中继转发表,看到全部active证明配置成功)

转载请注明:Slyar Home » CCNP实验:利用隧道扩展路由器模拟的帧中继交换机

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (6)

  1. @Slyar 谢谢
    老谢5年前 (2012-05-24)回复
  2. @老谢 学习指南,TCPIP路由技术
    Slyar5年前 (2012-05-24)回复
  3. @Slyar 人邮出版社的那套np认证考试指南?
    老谢5年前 (2012-05-23)回复
  4. @老谢 不素啊,这个是CISCO书里的
    Slyar5年前 (2012-05-23)回复
  5. 博主看的lisir的视频自学?这个拓扑和我看lisir的视频里面的一模一样,除了DLCI号 = =!
    老谢5年前 (2012-05-23)回复
  6. 很强悍的技术,多谢博主分享!
    [广告屏蔽]5年前 (2011-08-29)回复