最新消息:点击查看大S的省钱秘笈

EIGRP不等价负载均衡-执行variance后的可行后继

网络相关 Slyar 64浏览 0评论

文章作者:姜南(Slyar) 文章来源:Slyar Home (www.slyar.com) 转载请注明,谢谢合作。

拓扑如图,网段已经标出,左边端口1,右边端口2,全部启用EIGRP,R2、R3、R4当成透明就行了,文章最下面附有R1和R5部分配置。

本文主要分析一个问题:在EIGRP上使用variance开启不等价负载均衡后,选择可行后继路由器的AD<FD规则中,FD的值是原本的FD值还是翻倍后的FD值。即原本不能被当做可行后继路由器的路由器,在使用variance命令后能否变为后继路由器。

我修改了R3和R4的bandwidth以使得AD值不同,下面是variance为默认值1时的路由表及拓扑数据库(部分)。

R1#sh ip ro ei
D 192.168.0.0/24
[90/158720] via 1.2.0.2, 00:01:30, FastEthernet0/0

R1#sh ip ei top
IP-EIGRP Topology Table for AS(1)/ID(1.4.0.1)
P 192.168.0.0/24, 1 successors, FD is 158720
via 1.2.0.2 (158720/156160), FastEthernet0/0
via 1.3.0.2 (159232/156672), FastEthernet1/0

可以看到只有1条途径R1的后继路由,可行后继也只有1条途径R3的路由,因为R3的AD值156672<当前最小FD值158720。

R1#sh ip ei top all
IP-EIGRP Topology Table for AS(1)/ID(1.4.0.1)
P 192.168.0.0/24, 1 successors, FD is 158720, serno 21
via 1.2.0.2 (158720/156160), FastEthernet0/0
via 1.3.0.2 (159232/156672), FastEthernet1/0
via 1.4.0.2 (163072/160512), FastEthernet2/0

而途径R4的路由就没有被当做可行后继,因为R4的AD值160512>当前最小FD值158720。

此时修改variance的值为2,即小于2*FD的路由均可以作为后继路由,那么R4能否被当做后及路由呢?

R1(config)#router ei 1
R1(config-router)#variance 2

R1#sh ip ro ei
D 192.168.0.0/24
[90/159232] via 1.3.0.2, 00:01:43, FastEthernet1/0

[90/158720] via 1.2.0.2, 00:01:43, FastEthernet0/0

R1#sh ip ei top
IP-EIGRP Topology Table for AS(1)/ID(1.4.0.1)
P 192.168.0.0/24, 1 successors, FD is 158720
via 1.2.0.2 (158720/156160), FastEthernet0/0
via 1.3.0.2 (159232/156672), FastEthernet1/0

可以看到路由表中已经出现2条去往192.168.0.0/24的路由条目,但是R4依旧没有出现。

结论:在EIGRP上使用variance开启不等价负载均衡后,选择可行后继路由器的AD<FD规则中,FD的值是原本的FD值。即原本不能被当做可行后继路由器的路由器,在使用variance命令后依旧不能成为后继路由器。

R1部分端口及路由协议配置:

!
interface FastEthernet0/0
ip address 1.2.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 1.3.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 1.4.0.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
variance 2
network 1.2.0.0 0.0.0.255
network 1.3.0.0 0.0.0.255
network 1.4.0.0 0.0.0.255
no auto-summary
!

R5部分端口及路由协议配置:

!
interface Loopback1
ip address 192.168.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 2.5.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
bandwidth 98000
ip address 3.5.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
bandwidth 85000
ip address 4.5.0.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 2.5.0.0 0.0.0.255
network 3.5.0.0 0.0.0.255
network 4.5.0.0 0.0.0.255
network 192.168.0.0
no auto-summary
!

转载请注明:Slyar Home » EIGRP不等价负载均衡-执行variance后的可行后继

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址